Degraded Performance in Sending Email Messages and functionality of Campaing and Automations tabs

Incident Report for Omnisend

Resolved

We’ve confirmed the issue has been fully resolved and services are back to normal.
Posted Mar 13, 2026 - 12:38 UTC

Update

We are continuing to investigate this issue.
Posted Mar 13, 2026 - 11:03 UTC

Investigating

Our team is investigating and working to resolve this as quickly as possible.
Posted Mar 13, 2026 - 10:56 UTC
This incident affected: Channels (Email), Platforms (Shopify, BigCommerce, WooCommerce, Wix), and Product Area (Campaigns, Automation).