Omnisend - Missing navigation

Incident Report for Omnisend

Resolved

This incident has been resolved.
Posted May 06, 2025 - 13:36 UTC

Identified

We are experiencing a brief technical issue. Your automated messages and scheduled campaigns are running smoothly, and none of your data is affected. We appreciate your patience while we sort things out.
Posted May 06, 2025 - 13:30 UTC
This incident affected: Product Area (API, Campaigns, Automation, Segments, Signup Forms, Reporting, Integrations, Access).