Login issues

Incident Report for Omnisend

Resolved

We've confirmed that the issue has been fully resolved and all services are back to normal. Logins are working as expected. Thank you for your patience.
Posted Apr 30, 2026 - 13:37 UTC

Update

A fix has been deployed, and we are currently monitoring its effectiveness.
Posted Apr 30, 2026 - 13:33 UTC

Update

We are continuing to investigate this issue.
Posted Apr 30, 2026 - 13:30 UTC

Investigating

We’re currently experiencing some issues with our login and app.omnisend.com page. Our team is currently working on fixing the issue, We appreciate your patience while we work to restore normal service
Posted Apr 30, 2026 - 13:28 UTC
This incident affected: Product Area (Access).