Data Update Delay

Incident Report for Omnisend

Resolved

A fix has been implemented, and everything is now fully restored.
Posted Apr 10, 2026 - 18:04 UTC

Monitoring

We’re continuing to monitor the fix while data catches up. We’ll share another update once everything is fully restored.
Posted Apr 10, 2026 - 14:32 UTC

Identified

We’ve applied a fix and are currently monitoring the results. Data should start catching up within the next few hours.
Posted Apr 10, 2026 - 14:25 UTC

Update

We are continuing to investigate this issue.
Posted Apr 10, 2026 - 14:23 UTC

Investigating

Some data is currently not updating as expected. Our team has identified the issue and is working on a fix. We’ll share updates as soon as possible.
Posted Apr 10, 2026 - 14:22 UTC
This incident affected: Channels (Email, SMS, Push Notifications), Platforms (Shopify, BigCommerce, WooCommerce, Wix), and Product Area (Automation, Segments, Reporting).