Delay in email campaigns sending

Incident Report for Omnisend

Resolved

This incident has been resolved.
Posted Jan 04, 2023 - 17:25 UTC

Monitoring

A fix has been implemented and we are monitoring results. All postponed campaigns are now sent. There does not seem to be any more delays in email campaign sending.
Posted Jan 04, 2023 - 13:55 UTC

Investigating

We are currently investigating this incident.
Posted Jan 04, 2023 - 13:36 UTC
This incident affected: Channels (Email) and Product Area (Campaigns).