Contact export not loading

Incident Report for Omnisend

Resolved

This incident has been resolved. Thanks for your patience
Posted Jul 22, 2025 - 14:47 UTC

Update

We’ve confirmed the issue has been fully resolved and services are back to normal. Thanks for your patience
Posted Jul 22, 2025 - 14:45 UTC

Monitoring

The fix has been implemented and we are monitoring the results.
Posted Jul 22, 2025 - 13:17 UTC

Investigating

We’re currently investigating a potential issue that could be affecting parts of the platform.
Posted Jul 22, 2025 - 13:01 UTC
This incident affected: Product Area (Segments).