Issues with brand switching and some specific interactions within the application
Incident Report for Omnisend
Resolved
This incident has been resolved.
Posted Feb 21, 2024 - 14:19 UTC
Investigating
We are noticing issues with switching from one brand to another within the account, opening and editing automations or campaigns, loading brand-specific data.

The data itself is not lost or damaged.

We are currently investigating this.
Posted Feb 21, 2024 - 13:22 UTC
This incident affected: Product Area (API, Campaigns, Automation, App).