We’re currently investigating a potential issue that could be affecting parts of the platform. We’ll provide more details as soon as we have them.

Incident Report for Omnisend

Resolved

This incident has been resolved.
All systems are now operating normally. Thank you for your patience.
Posted Sep 17, 2025 - 13:01 UTC

Investigating

We are currently investigating this issue.
Posted Sep 17, 2025 - 12:55 UTC
This incident affected: Platforms (WooCommerce).