Customer breakdown page does not display number of contacts in each stage

Incident Report for Omnisend

Resolved

This incident has been resolved.
Posted Jun 16, 2025 - 18:05 UTC

Monitoring

A fix has been implemented, and we are currently monitoring the results to ensure full recovery. We’ll continue to provide updates as necessary.
Posted Jun 16, 2025 - 13:15 UTC

Identified

During the Google Cloud Platform (GCP) outage last week, one of our RFM services experienced a disruption and did not automatically recover. We are currently working to bring the service back online and will provide updates as progress is made.
Posted Jun 16, 2025 - 13:14 UTC

Investigating

We are currently investigating this incident.
Posted Jun 16, 2025 - 11:24 UTC
This incident affected: Platforms (Shopify, BigCommerce, WooCommerce, Wix) and Product Area (Reporting).