Login page is down

Incident Report for Omnisend

Resolved

This incident has been resolved.
Posted Sep 18, 2025 - 11:35 UTC

Investigating

We’re currently investigating a potential issue with the Login page that could be affecting parts of the platform.
Posted Sep 18, 2025 - 11:31 UTC
This incident affected: Product Area (Access).