A/B Campaign Date Change Issue

Incident Report for Omnisend

Resolved

This incident has been resolved.
Posted May 26, 2026 - 08:27 UTC

Identified

We are aware of an issue where some campaigns are displaying unexpected date changes. This is a known issue currently being investigated by our development team — no account data has been affected and no campaigns have been sent or modified. We will provide further updates as our investigation progresses.
Posted May 26, 2026 - 01:44 UTC
This incident affected: Channels (Email).