Support Communication Delays

Incident Report for Omnisend

Resolved

The issue has been resolved now - our support is fully reachable. We appreciate your patience.
Posted Oct 21, 2025 - 07:02 UTC

Identified

We are currently experiencing an issue where some customer messages may not be reaching our support team or may experience delays. This is due to an ongoing incident with one of our third-party communication service providers.
We’ll share more updates as soon as we have additional information.
Posted Oct 20, 2025 - 09:44 UTC