Delay in E-mail Sending

Incident Report for Omnisend

Resolved

We’ve confirmed the issue has been resolved and services are back to normal.
Thank you for bearing with us.
Posted Sep 12, 2025 - 11:39 UTC

Update

This incident has been resolved.
All systems are now operating normally. Thank you for your patience.
Posted Sep 12, 2025 - 10:59 UTC

Update

A fix has been deployed and we are currently monitoring its effectiveness.
We’ll update you once we confirm the issue has been fully resolved.
Posted Sep 12, 2025 - 10:41 UTC

Update

We’re continuing to investigate the issue and will share more details as soon as they become available.
Thanks for your patience.
Posted Sep 12, 2025 - 10:29 UTC

Update

The delay is visible only for email Campaigns.
Posted Sep 12, 2025 - 10:28 UTC

Update

We are continuing to investigate this issue.
Posted Sep 12, 2025 - 10:26 UTC

Investigating

We are currently investigating this incident.
Posted Sep 12, 2025 - 10:21 UTC
This incident affected: Channels (Email), Platforms (Shopify, BigCommerce, WooCommerce, Wix), and Product Area (Campaigns, Automation).