"Something went wrong. Please reload the page or contact support"

Incident Report for Omnisend

Resolved

This incident has been resolved.
Posted Apr 20, 2026 - 17:02 UTC

Update

We are continuing to investigate this issue.
Posted Apr 20, 2026 - 16:58 UTC

Update

We are continuing to investigate this issue.
Posted Apr 20, 2026 - 16:56 UTC

Investigating

We’re currently experiencing an issue affecting campaign sending. You may see an error such as “Something went wrong. Please reload the page or contact support.”

Our team is aware of this and is actively working to resolve it. We appreciate your patience while we restore normal functionality.
Posted Apr 20, 2026 - 16:44 UTC
This incident affected: Channels (Email, SMS).