Problem with the Email Builder

Incident Report for Omnisend

Resolved

This incident has been resolved.
Posted Mar 16, 2026 - 16:17 UTC

Investigating

We’re currently experiencing an issue with our Email Builder. You may see a message that says ‘Powered by Froala Editor’ within your email block. Our team is actively working to restore normal service. Thank you for your patience.
Posted Mar 16, 2026 - 15:08 UTC
This incident affected: Channels (Email), Platforms (Shopify, BigCommerce, WooCommerce, Wix), and Product Area (Campaigns, Automation).